Acronis Cyber Protect 15
【安克諾斯 Acronis】Cyber Protect:在 Windows上安裝Acronis代理失敗並顯示MSI錯誤
知識庫編號: | 上次更新時間:2023-12-01
本文適用於以下產品 Acronis Cyber Protect 15
問題說明
1。您正在 Windows 上安裝 Acronis 代理。
2。安裝失敗,MSI 代碼為 1603。
安裝程式 GUI 中的通用錯誤訊息範例:

完整的錯誤訊息:
MSI (s) (4C:44) [09:33:58:012]: Doing action: SetArpInstallLocation
MSI (s) (4C:44) [09:33:58:012]: Note: 1: 2205 2: 3: ActionText
Fin de l’action 09:33:58 : CostFinalize. Valeur renvoyée : 1.
MSI (s) (4C:44) [09:33:58:012]: PROPERTY CHANGE: Adding ARPINSTALLLOCATION property. Its value is 'C:\Program Files\BackupClient\'.
Début de l’action 09:33:58 : SetArpInstallLocation.
MSI (s) (4C:44) [09:33:58:012]: Doing action: CADataInitCA
MSI (s) (4C:44) [09:33:58:012]: Note: 1: 2205 2: 3: ActionText
Fin de l’action 09:33:58 : SetArpInstallLocation. Valeur renvoyée : 1.
*MSI (s) (4C:1C) [09:33:58:012]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI4050.tmp, Entrypoint: CADataInit*
*Début de l’action 09:33:58 : CADataInitCA.*
CustomAction CADataInitCA returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Fin de l’action 09:34:10 : CADataInitCA. Valeur renvoyée : 3.
Fin de l’action 09:34:10 : INSTALL. Valeur renvoyée : 3.
Property(S): InstallMode = Typical
Property(S): UpgradeCode = {DAC56B69-1A5E-494D-92AE-A462FFB2A281}
Property(S): WINDOWS_INSTALLATION_TYPE = Server
Property(S): manufacturermenu = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Acronis\
Property(S): TARGETDIR = C:\Program Files\BackupClient\
Property(S): SYSTEMMONITORDIR = C:\Program Files\Common Files\Acronis\Drivers\SystemMonitor\
Property(S): FILEMONITORDIR = C:\Program Files\Common Files\Acronis\Drivers\FileMonitor\
Property(S): ALLUSERS = 1
-
原因
該錯誤是由以前嘗試安裝的 Acronis 代理或其他不相關軟體的殘留檔案引起的。 這是 Windows 環境中很少出現的人為遺留痕跡。
另一個可能的原因是防病毒/反惡意軟體可能會干擾對安裝程式臨時檔的訪問。
這兩種原因也有可能同時發生。 -
解決方法
1。從以下臨時位置刪除子文件夾和文件:
• C:\ Users \ Administrator \ AppData \ Local \ Temp\
• C:\ Windows \ Installer \ MSI。tmp,在哪裡 它是臨時文檔的自動生成的名稱。
2。再次運行安裝程序。 -
其他資訊
如果這不能解決問題,建議:
• 聯繫Acronis支援
• 嘗試新安裝時收集ProcMon (PML)
• 先壓縮 PML,然後再將其上傳到 Acronis 支援提供的 FTP
• 提供命令提示字元下“set”的輸出結果 -
原文連結
聯絡資訊
如需更多資訊,請與湛揚技術服務中心聯繫,我們將竭誠為您服務!
服務信箱:support@t-tech.com.tw
客服專線:(02)2515-1599
週一至週五 (不含國定假日) 09:00~12:30;13:30~18:00